Target Networking

The blog includes a vivid coverage of the concepts of CCNA, CCNP (Routing & Switching) , Basic Linux and Linux servers. Projects have also been simulated to give a practical exposure.

Friday 30 May 2014

No comments

Etherchannel in GNS3



The method to increase the bandwidth by aggregating or bundling parallel links is known as EtherChannel.

To confirm working of this lab, 192.168.1.1 ip should ping from 192.168.1.2 ip address.

In this topology all the ports are in access mode, so all ports belong to same VLAN i.e vlan 10. There are 6 physical links in between the Switch R1 and R2. 1 port-channel group is made on both the switches. On switch R1 there is a vlan 10 interface which contain ip 192.168.1.1/30.  

Conditions of EtherChannel :-

Each EtherChannel can have, two to eight links of either Fast Ethernet (FE), Gigabit Ethernet (GE), or 10-Gigabit Ethernet (GE) as a logical link of Fast EtherChannel (FEC), Gigabit EtherChannel (GEC), or 10-Gigabit EtherChannel (10GEC) respectively. This bundle provides bandwidth according to the links. 

Configure all the interfaces to operate on same speed and same duplex.

Enable all interfaces in EtherChannel. A interface can be shut to check the redundancy.

An EtherChannel does not form if ports are configured with dynamic VLANs.

If ports are access ports then they should be in same VLAN

If ports are trunk ports then allowed VLANs on the trunk port should be same. Trunking Encapsulation should be same on all ports. 

EtherChannel avoids bridging loops by combining the links into single logical link. This link can be act as access or trunk, depend on the topology. Traffic is distributed on the links according to the hashing algorithm, each link of FEC has the capacity of 200Mbps, carry upto 200Mbps. but logical link capacity is 800Mpbs. These links carry only those frames which are placed by EtherChannel on it. It is also provide redundancy for the links, when one link got broken from bundle then the traffic of that link got distributed over other links. By this it helps to get rid of failover. And when that link got up again the traffic is redistributed again. 

Distribution of Traffic :- 
Traffic over EtherChannel got distributed as  a result of hashing algorithm. The algorithm can use source and destination MAC address, source and destination IP address etc. Algorithm calculate a binary pattern that selects a link in the bundle to carry the frame. If there are only two links in the bundle then 1-bit index got generated. If the index is 0 then link 0 is selected, if it is 1 then link 1 is selected. For 4 link bundle hash use last 2 bits whereas for 8 link bundle 3 bits. 

Load Balancing Methods :-
There are 9 methods for load balancing in EtherChannel.

Method value                             Hash Input
1.src-ip                                        Source IP address
2.dst-ip                                        Destination IP address
3.src-dst-ip                                  Source & Destination IP address
4.src-mac                                    Source MAC address
5.dst-mac                                    Destination MAC address
6.src-dst-mac                              Source & Destination MAC 
7.src-port                                    Source port number
8.dst-port                                    Destination port number
9.src-dst-port                              Source & Destination port

EtherChannel Protocols :-
There are two types of protocols used in EtherChannel.
1. PAgP
2. LACP

Configuration of Switch R1 :-

interface Port-channel1
 switchport access vlan 10
!
interface FastEthernet1/0
 switchport access vlan 10
 duplex full
 speed 100
 channel-group 1 mode on
!
interface FastEthernet1/1
 switchport access vlan 10
 duplex full
 speed 100
 channel-group 1 mode on
!
interface FastEthernet1/2
 switchport access vlan 10
 duplex full
 speed 100
 channel-group 1 mode on
!
interface FastEthernet1/3
 switchport access vlan 10
 duplex full
 speed 100
 channel-group 1 mode on
!
interface FastEthernet1/4
 switchport access vlan 10
 duplex full
 speed 100
 channel-group 1 mode on
!
interface FastEthernet1/5
 switchport access vlan 10
 duplex full
 speed 100
 channel-group 1 mode on
!
interface Vlan10
 ip address 192.168.1.1 255.255.255.252


Same Configuration would be on Switch R2 except interface vlan 10.

Configuration of Switch R3 :- 

interface FastEthernet1/0
 no switchport
 ip address 192.168.1.2 255.255.255.252
 duplex full
 speed 100

Verification 

Ping from 192.168.1.2 to 192.168.1.1 :-

R3-SW#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/24/32 ms

Thursday 29 May 2014

No comments

Inter vlan routing on GNS3




VLAN is the part of switching in networking, it is essential part of switch. Basically VLAN divides the switch into parts. VLANs are isolated from one from each other so that packets in one VLAN cannot communicate with other VLAN.
 To send packets from one VLAN to other, a Layer 3 device is needed. If router is used for this function then it must have a physical or logical connection to each VLAN so it can transfer packets between them. This is known as interVLAN routing.

In this topology Layer 3 device is Router R2, switch on which VLANs are created is SW1 and there are 4 hosts, connected to the switch, in which host C1, C2 are in VLAN 10 and C3, C4 are in VLAN 20.

When Host C1 in VLAN 10 needs to communicate with Host C2 in VLAN 10, it sends a packet
addressed to that host, Switch SW1 forwards the packet directly to Host C2, without sending it to the router. And when C1 want to communicate with C3 or C4 which are inn VLAN 20, then switch SW1 forwards the packets of C1 to router and router receive the traffic, send it to Hosts C3, C4 which are in VLAN 20. Router R2 is connected through two links with switch SW1, interface f0/0 is used for VLAN 10 and f0/1 is for VLAN 20.

Configuration of Router R2 :-

interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
 !
interface FastEthernet0/1
 ip address 20.0.0.1 255.255.255.0
 duplex auto
 speed auto

Configuration of Switch SW1 :-


All VLANs type is access.

Configuration of Hosts :-

The hosts used here are VPCS hosts. It is the integrated feature of GNS3.

VPCS[1]> ip 10.0.0.2 255.255.255.0 10.0.0.1

 VPCS[1]> ip (ip addresss) (netmask) (gateway)


Verification

Ping Host C1 from C2 :- 
(Both the Hosts are in same vlan.)


Ping Host C3 from C1 :-
(Both are in different vlans)



 

Wednesday 21 May 2014

No comments

IPv6 Tunnel over MPLS & eBGP Network




In this lab, same concept, IPv6 tunneling is used, as it is used in my previous lab IPv6 Tunnel over IPv4 Network. Concept of making tunnel over the network is same but in both the topologies network is different. In my previous lab there is normal network running EIGRP as routing protocol but here network is comprises of MPLS L3 VPN, eBGP and some other concepts like GLBP, VRRP etc.

In this topology IPv6 tunnel is made from Server_router to SEMBO_TECH router. Between these two routers there are redundant paths. one path is from MPLS Layer 3 VPN and other is of eBGP. From Server_router side, GLBP protocol is used for redundancy whereas on SEMBO_TECH side VRRP protocol is used. IPv6_host is the DHCPv6 host of SEMBO_TECH IPv6 DHCP server.

In lab IPv6 Tunnel over IPv4 Network , concept of Router-ID is shown, because there is two routers on which there is no IPv4 addresses so we have to give Router-ID to the router. This concept is not applicable here because on all the routers have IPv4 addresses, so there is no need of Router-ID.

In eBGP path, loopback interfaces are made for routing in BGP, because loopback interface is a logical interface so it will remain up forever. On other path MLPS Layer 3 VPN, a VPN with MPLS is made over PE2 ---> P---> PE1 routers. MPLS L3VPN is a PE-based L3VPN technology for service provider VPN solutions. It uses BGP to advertise VPN routes and uses MPLS to forward VPN packets on service provider backbones. It provides flexible networking modes, excellent scalability, and convenient support for MPLS QoS.

The MPLS L3VPN model consists of three kinds of devices:
  • Provider edge router (PE): A PE resides on a service provider network and connects one or more CEs to the network. On an MPLS network, all VPN processing occurs on the PEs.

  • Provider (P) router: It is a backbone router on a service provider network. It is not directly connected with any CE. It only needs to be equipped with basic MPLS forwarding capability.

  • Customer edge device (CE): A CE resides on a customer network and has one or more interfaces directly connected with service provider networks. It can be a router, a switch, or a host. It neither can "sense" the existence of any VPN nor needs to support MPLS.

IPv6 Tunnel

On Router Server_router :-

interface Tunnel0
  no ip address
 ipv6 address 2015::1/64
 ipv6 enable
 ipv6 eigrp 1
 tunnel source FastEthernet0/1
 tunnel destination 192.168.99.1
 tunnel mode ipv6ip

On Router Server_router :-

interface Tunnel0
 no ip address
 ipv6 address 2015::2/64
 ipv6 enable
 ipv6 eigrp 1
 tunnel source FastEthernet0/0
 tunnel destination 20.3.0.1
 tunnel mode ipv6ip

Verification 


Ping from Server_router to IPv6_host

Server_router#ping 2006::C805:12FF:FE58:8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2006::C805:12FF:FE58:8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 120/177/260 ms

 Ping from IPv6_host to Server_host

IPv6_host#ping 2015::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2015::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 108/133/152 ms

Configuration File config.zip

If you are interested in procuring the .net file for GNS3 then enter your email id in comment box.

By : Vishal Sharma

Tuesday 20 May 2014

No comments

IPv6 Tunnel over IPv4 Network


In this topology IPv6 tunnel is made over IPv4 network, color dark red representing the IPv4 network whereas color blue is showing IPv6 Network with IPv6 tunnel. EIGRP routing protocol is used for communication between both network IPv4 as well as IPv6. IPv4 network is using EIGRP 1 and IPv6 network is using EIGRP 2.

This topology is a example of Manually Configured Tunnel (MCT) which is a type of Static Point-to-Point IPv6 Tunnel. This lab is based on Manually Configured tunnel in which Tunnel mode is ipv6ip. RFC 4213 is made for this MCT tunnel.
There are two types of Static Point-to-Point tunnel :-
1. Manually Configured Tunnels (MCT)
2. Generic Routing Encapsulation (GRE) tunnels

In order to support the IGP`s and other features in these static tunnels router will assign link local addresses on these links and allow the forwarding of IPv6 multicast traffic.

This topology is clearing the concept that, if Router has only IPv6 addresses over it and no IPv4 addresses then we have to give Router-ID in the routing protocol otherwise that router will not communicate with the other routers because it will not have any route to other routers.
So here Router R5 and R6 has the Router-ID 5.5.5.5 and 6.6.6.6 .
Tunneling is one of the way to communicate IPv6 with IPv4 network. In this topology IPv6 tunnel is made from Router R1 to R4, and this tunnel has the IP address from subnet 2003::/64.

In GNS3, IPv6 routing have to be enabled on interface, it can not enabled by the network command in routing protocol.

IPv6 Tunnel

On Router R1-
interface Tunnel0

no ip address
ip mtu 1000
ipv6 address 2003::1/64
ipv6 eigrp 2
tunnel source FastEthernet0/0
tunnel destination 10.3.0.2
tunnel mode ipv6ip


On Router R4-
interface Tunnel0

no ip address
ip mtu 1000
ipv6 address 2003::2/64
ipv6 eigrp 2
tunnel source FastEthernet0/0
tunnel destination 10.1.0.1
tunnel mode ipv6ip


Router-ID for Router R5 :-
ipv6 router eigrp 2
 eigrp router-id 5.5.5.5

Router-ID for Router R6 :- 
ipv6 router eigrp 2 
 eigrp router-id 6.6.6.6

Verification of the tunnel :-

R1#show interfaces tunnel 0
Tunnel0 is up, line protocol is up
  Hardware is Tunnel
  MTU 17920 bytes, BW 100 Kbit/sec, DLY 50000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 10.1.0.1 (FastEthernet0/0), destination 10.3.0.2
  Tunnel protocol/transport IPv6/IP

  Tunnel TTL 255
  Tunnel transport MTU 1480 bytes
  Tunnel transmit bandwidth 8000 (kbps)
  Tunnel receive bandwidth 8000 (kbps)
  Last input 00:00:00, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     386 packets input, 60398 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     392 packets output, 40546 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out


The highlighted texts shows that tunnel interface is up, the output confirms the source and destination IPv4 addresses. It also confirms that the tunnel mode uses IPv6 over IP, tunnel transport MTU is 1480 bytes for MCT for others, like GRE it is 1476 bytes. In case of MCT link local addresses for interface is based on FE80::/96, plus 32 bits from tunnel source IPv4 address.

GRE Tunnel

 In this topology i changed the tunnel mode from ipv6ip to gre ip. Firstly remove tunnel mode ipv6ip by applying no tunnel mode ipv6ip command and then apply tunnel mode gre ip command.

R1#show interfaces tunnel 0
Tunnel0 is up, line protocol is up
  Hardware is Tunnel
  MTU 17916 bytes, BW 100 Kbit/sec, DLY 50000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 10.1.0.1 (FastEthernet0/0), destination 10.3.0.2
  Tunnel protocol/transport GRE/IP
    Key disabled, sequencing disabled
    Checksumming of packets disabled

  Tunnel TTL 255
  Fast tunneling enabled
  Tunnel transport MTU 1476 bytes

  Tunnel transmit bandwidth 8000 (kbps)
  Tunnel receive bandwidth 8000 (kbps)
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     700 packets input, 104149 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     711 packets output, 73539 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out

Here this output is showing that the protocol used for the tunnel is GRE/IP and transfer MTU is of size 1476 bytes which is 4 bytes lesser than IPv6IP. This 4 bytes is the additional GRE header. In case of GRE tunnel Link local address for interfaces is based on IPv6 EUI-64, using lowest numbered interface`s MAC address. RFC 2784 is used for GRE.

Ping from Router R5 to R6
R5#ping 2002::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/106/212 ms

  
Ping from Router R6 to R5
R6#ping 2001::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/78/88 ms


Traceroute from R5 to R6

R5#traceroute 2002::1
Type escape sequence to abort.
Tracing the route to 2002::1


  1 2001::2 56 msec 8 msec *
  2 2003::2 80 msec 72 msec 56 msec
  3 2002::1 104 msec 76 msec 44 msec


Configuration File config.zip

If you are interested in procuring the .net file for GNS3 then enter your email id in comment box.

  By :- Vishal Sharma

Friday 16 May 2014

No comments

%DUAL-5-NBRCHANGE: IP-EIGRP(0)


I searched everywhere on internet about this error. I faced this error yesterday, on internet i found that this error is due to MTU packet size. It is quite surprising for me that MTU is creating problem, because I have learned that router perform fragmentation, segmentation if packet is large. But I found that these processes does not occur in this case. Because all EIGRP packets are trasported as IP protocol type 88 using Reliable Transport Protocol (RTP), not TCP or UDP, while Fragmentation is the mechanism in TCP transport.

EIGRP has a problem of flapping (up/down) in some topologies. It makes the network unstable, which creates problem in communication. This problem shows errors like this :-
 
%DUAL-5-NBRCHANGE: IPv6-EIGRP(0) 1: Neighbor FE80::2 (Tunnel0) is up: new adjacency

%DUAL-5-NBRCHANGE: IPv6-EIGRP(0) 1: Neighbor FE80::2 (Tunnel0) is down: holding time expired

It is the case of IPv6 tunneling.

Same error is also given in IPv4 likewise :- 

%DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.1.1 (Tunnel3) is up: new adjacency

Basically this error is due to the EIGRP, By default, MTU size is 1500 in each router, this MTU size creates the problem in communication. So it can be solved by reducing the MTU size.  

So in last I got this explanation for this error :-

Two routers peer with MTU of 1500, but in the path between them there is a L2 hop that has a smaller MTU.  1492 for example.  The two routers will hello and establish neighbor with smaller than 1492 packets and have no problem.  The first time one of the routers tries to send routes to the other router the packet will likely exceed the 1492 MTU and be dropped along the way.  The router will retransmit several times and never get the ack, then it will dump the neighbor relationship and re-learn the neighbor - <repeat until someone figures the problem out>.  In a topology with multiple paths this type of problem can be delayed in manifesting itself because EIGRP doesn't share routes with neighbors unless they ask for them.  I had this problem occur three days after deploying a new L2 WAN circuit because there was no significant EIGRP convergence event until 3 days later.  Lesson learned -> always "ping size 1500 df-bit x.x.x.x" new WAN paths. 


By :- Vishal Sharma

Wednesday 14 May 2014

No comments

Layer 3 Switch in GNS3

GNS3 is a cisco simulator to perform network analysis without cost. GNS3 has very good features like Router, Switch, ATM switch, Frame Relay Switch, host(vpcs) etc, but it also has a limitation in switching, all the concepts of switching can not be perform on GNS3. This due to compatibility of GNS3 with switch chip.
In GNS3 there is a layer 3 switch icon in images, but we can not use it without having c3725 IOS image. 3725 IOS image is the image used in two way.
1. 3725 router
2. Layer 3 switch.

So to emulate Layer 3 switch in GNS3, we have to follow some steps :-

1. Install GNS3
                   Simple Steps for Installation of GNS3.
2. Try to get the c3725-spservicesk9-mz.124-21 from your sources. 
                   Download c3725-spservicesk9-mz.124-21 IOS Image.
 
3. Add 3725 IOS Image to GNS3.
                   Add IOS Image to GNS3. 

4. Now, on symbols bar, drop the EtherSwitch Router and fire it up.

By :- Vishal Sharma 

Sunday 11 May 2014

No comments

Protocols Redistribution

Internet constitutes with different -2 protocols, so, to advertise routes from one protocol to another protocol redistribution process is used. 





In this topology Redistribution_point router is the mid point of the topology, to which each protocol is connected. All most all protocols are used in this topology and they distribute their routes to the other protocols through redistribution process.

Configuration of Redistribution_point router :-


IP addresses over Interfaces


interface FastEthernet0/0
 ip address 10.0.1.2 255.255.255.0
!
interface FastEthernet0/1
 ip address 10.0.2.2 255.255.255.0
!
interface FastEthernet1/0
 ip address 10.0.5.2 255.255.255.0
!
interface FastEthernet1/1
 ip address 10.0.4.2 255.255.255.0
!
interface FastEthernet2/0
 ip address 10.0.3.2 255.255.255.0

Routing protocols configuration :-


router eigrp 1
 redistribute static metric 100000 100 255 255 1500
 redistribute ospf 1 metric 100000 100 255 255 1500
 redistribute rip metric 100000 100 255 255 1500
 redistribute bgp 1 metric 100000 100 255 255 1500
 network 10.0.1.0 0.0.0.255
 auto-summary
router ospf 1
 log-adjacency-changes
 redistribute static metric 100000 metric-type 1 subnets
 redistribute eigrp 1 metric 100000 metric-type 1 subnets
 redistribute rip metric 100000 metric-type 1 subnets
 redistribute bgp 1 metric 100000 metric-type 1 subnets
 network 10.0.2.0 0.0.0.255 area 0
router rip
 version 2
 redistribute static metric 1
 redistribute eigrp 1 metric 1
 redistribute ospf 1 metric 1
 redistribute bgp 1 metric 1
 network 10.0.0.0
 no auto-summary
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 10.0.5.0 mask 255.255.255.0
 redistribute static metric 1000000
 redistribute eigrp 1 metric 10000000
 redistribute ospf 1 metric 10000000
 redistribute rip metric 10000000
 neighbor 10.0.5.1 remote-as 1
 no auto-summary
ip forward-protocol nd
ip route 10.0.3.0 255.255.255.0 FastEthernet2/0


Configuration of Topology :- protocols_redistribution.zip

By :- Vishal Sharma

Saturday 10 May 2014

1 comment

DHCP server on Switch in GNS3

DHCP server is the server which provides IP address dynamically to the host. In GNS3 IOS 3725 image is used as Layer 3 Switch. It has NM-16ESW slot which has 16 fastethernet ports.





In this topology R1 is Layer 3 switch and SW1 is Layer 2 switch (unconfigurable), 2 hosts. Switch R1 has DHCP server which gives IP address automatically to the hosts.

Configuration of Layer 3 switch R1 :-

IP address on interface

interface FastEthernet1/0
 no switchport
 ip address 10.0.0.1 255.255.255.0
 duplex full
 speed 100

DHCP pool on router :-


ip dhcp pool cisco
network 10.0.0.0 255.255.255.0
default-router 10.0.0.1

Start DHCP service

 # service dhcp

On Layer 3 switch, dhcp service has to start, without this service dhcp server will not start working.

On router this service is enabled by default.

 

 Automatic IP address on Host_1 and Host_2
On Host_1


On Host_2



In last whole topology is working.

By :- Vishal Sharma
No comments

Add IOS image to GNS3

To use GNS3 in a proper manner, then one needs to know how to add IOS Image to GNS3. Because if a person do not know to add IOS image in GNS3 then he can not use Router, Switches and other features of the GNS3.

To add IOS image to GNS3, follow these steps :-

Step1. Install GNS3 in computer.

 

Simple steps to install GNS3.


Step2. Go to Edit ---> IOS Images and Hypervisors 




Select Image file in settings from your computer.
 

Step3 Calculation of IDLE PC :-

 

Click on IDLE PC to calculate Idle pc value, if there is no idle pc value then it will take 128 MB for each router, by which we can use only 3 -6 router if we have 4 GB RAM. Idle pc is the value on which router run on 0% usage of CPU. By which we can use 15 - 25 routers with 4GB RAM.

Step4 Save configuration :-

 

Save configuration by click on save.

By :- Vishal Sharma

Friday 9 May 2014

No comments

Connect GNS3 with Linux


This post assumes that reader has basic knowledge of GNS. For those who does not know they can visit GNS3 official website www.gns3.net.

To communicate GNS3 with Linux, simple steps have to follow :-
1. Create loopback interface.
2. IP address to loopback interface.
3. Connect loopback to GNS3.
4. Connect Linux to windows.
5. Assign IP address to Linux.

Step 1. Create Loopback interface 

Loopback is the logical interface given by Microsoft in windows. To create loopback interface follow these steps.
    a. Type windows key + R, it will open run.
    b. write hdwwiz.exe in run, press enter.


    c. click next, then choose install the hardware manually.




    d. click next ---> Network adapters ---> Microsoft ---> Microsoft KM-TEST Loopback Adapter.



    It will add a new loopback interface in Network and Sharing Center.


Step2. IP address to loopback interface :- 




    Here loopback interface name is Ethernet 2, and IP address given to this interface is 100.0.0.1

 Step3. Connect loopback to GNS3.

    a. Add 1 router and a cloud in GNS3.
    b. Select loopback interface Ethernet 2 in cloud.


     c. Assign IP address to Router 100.0.0.2/24.

Step4. Connect Linux to windows.

a.       Start Linux in VMware workstation.
b.      Open Virtual Network Editor (go to Edit -à Virtual Network Editor).
c.       Add a new network, select network as VMnet1, make it Bridged and select loopback interface there.
See there is a confusion here, if you have created more than 1 loopback interfaces then in Network and Sharing Center name of the loopback interfaces would be Ethernet 2 and 3 , but in VMware it will get recognized by Microsoft loopback for 1st and for 2nd it will be Microsoft loopback #2. So in VMware always 1 less counting is done for loopback. So do not confuse to select loopback.



     d. Now go to the setting and select VMnet1 as network. 


 Step5. Assign IP address to Linux.


    a. Open Terminal , type setup, select network there and enter IP address 100.0.0.254/24


    b. Turn off firewall of Linux by setenforce 0.

Now you can ping Linux from Router.

Ping from Router to Linux.




By :- Vishal Sharma

Tuesday 6 May 2014

No comments

IPv6 DNS Server on Linux

IPv6 DNS Name Resolution

IPv6 is of 128 bits, and each slot is of 16 bits, separated by column (:). It is very difficult to remember 128 bits address for each host and for each website. So Name Resolution can be done through DNS server.


DNS SERVER : DNS stands for DOMAIN NAME SERVER. DNS server is used to translate the IP address to HOSTNAME. In Linux Environment DNS server installed by BIND Packages. The name of service for DNS is NAMED.
DNS server is based on two versions of IP, 1 IPv4 DNS and 2. IPv6 DNS.
IPv4 DNS server is normal server which convert IPv4 address to hostname. But IPv6 DNS converts IPv6 address to hostname.
-          DNS server used hierarchical tree structure which include Host name, subdomain, 2nd level domain, top level domain.
-          DNS managed by ICANN (Internet Corporation Assign Name and Number ).
-          Total 13 Root- Domain work in DNS system in whole world (IPv6 Root Servers).

DNS Records :-
SOA  (start of authority) :- This record automatically created when ZONE fie created. This is the first record which is responsible for accept query and resolve it.
NS (Name Server) :- NS provide the domain name to clients.
CNAME  :-Alise name, Duplicate name
Host Record :- It is used to add the IP Address.
SPF (Sender Policy Framework) : - text record
TXT Record :- It is used for authentication purpose.

Two zone files are used to convert the IP address to Hostname.  


There are 5 files in which configuration should be change to make the DNS server.
  •   /etc/resolv.conf
  •    /etc/sysconfig/network 
  •    /etc/named.conf
  •   /var/named/chroot/var/named/for.zone    
  •   /var/named/chroot/var/named/res.zone
[root@server ~]# vim /etc/resolv.conf
The resolv.conf file contains directives with the default search domain or domains, used for FQDN completion when no domain suffix is supplied as part of the query. It also contains a list of IP addresses of nameservers available to a host. It usually looks like:


[root@server ~]# vim /etc/sysconfig/network
This file contain the configuration for enabling networking for IP version 4 and version 6 with HOSTNAME.

[root@server ~]# vim /etc/named.conf
This named.conf file contain the configuration for DNS server, and declaration of forward and reverse zone.



[root@server ~]# vim /var/named/chroot/var/named/for.zone
This file contain the configuration for forward zone. In which records like NS, A, AAAA, CNAME are placed. Here in this file A record is for IPv4 DNS and AAAA is for IPv6 DNS.

[root@server ~]# vim /var/named/chroot/var/named/res.zone
This file contains the PTR record for all the records of the Forward zone.



By :- Vishal Sharma