Presented a detailed study of the design, operation regarding how company offices access the servers (like DHCP, WEB, TFTP and DNS) over the internet. Concept of VLANs, BGP Routing, EIGRP Routing, OSPF Routing, Static Routing, Wireless Network, OSPF multi-area Tunneling, NAT, PAT and FRAME-RELAY were also demonstrated.
Configuration of Multilayer Switch0 :-
Switch#sh run
Building configuration...
Current configuration : 4131 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
ip dhcp excluded-address 192.168.10.1 192.168.10.2
ip dhcp excluded-address 192.168.20.1 192.168.20.2
ip dhcp excluded-address 192.168.30.1 192.168.30.2
ip dhcp excluded-address 192.168.40.1 192.168.40.2
ip dhcp excluded-address 192.168.50.1 192.168.50.2
ip dhcp excluded-address 192.168.60.1 192.168.60.2
ip dhcp excluded-address 192.168.70.1 192.168.70.2
ip dhcp excluded-address 192.168.80.1 192.168.80.2
ip dhcp excluded-address 192.168.90.1 192.168.90.2
!
ip dhcp pool vlan10
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 192.168.50.100
ip dhcp pool vlan20
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
dns-server 192.168.50.100
ip dhcp pool vlan30
network 192.168.30.0 255.255.255.0
default-router 192.168.30.1
dns-server 192.168.50.100
ip dhcp pool vlan40
network 192.168.40.0 255.255.255.0
default-router 192.168.40.1
dns-server 192.168.50.100
ip dhcp pool vlan50
network 192.168.50.0 255.255.255.0
default-router 192.168.50.1
dns-server 192.168.50.100
ip dhcp pool vlan60
network 192.168.60.0 255.255.255.0
default-router 192.168.60.1
dns-server 192.168.50.100
ip dhcp pool vlan70
network 192.168.70.0 255.255.255.0
default-router 192.168.70.1
dns-server 192.168.50.100
ip dhcp pool vlan80
network 192.168.80.0 255.255.255.0
default-router 192.168.80.1
dns-server 192.168.50.100
ip dhcp pool vlan90
network 192.168.90.0 255.255.255.0
default-router 192.168.90.1
dns-server 192.168.50.100
ip routing
!
spanning-tree mode pvst
spanning-tree vlan 50,60,70,80 priority 4096
spanning-tree vlan 10,20,30,40,90 priority 28672
!
interface FastEthernet0/1
no switchport
ip address 1.1.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/2
no switchport
ip address 3.3.3.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0
!
interface Vlan30
ip address 192.168.30.1 255.255.255.0
!
interface Vlan40
ip address 192.168.40.1 255.255.255.0
!
interface Vlan50
ip address 192.168.50.1 255.255.255.0
!
interface Vlan60
ip address 192.168.60.1 255.255.255.0
!
interface Vlan70
ip address 192.168.70.1 255.255.255.0
!
interface Vlan80
ip address 192.168.80.1 255.255.255.0
!
interface Vlan90
ip address 192.168.90.1 255.255.255.0
!
router eigrp 100
network 3.3.3.0 0.0.0.3
network 192.168.10.0
network 192.168.20.0
network 192.168.30.0
network 192.168.40.0
network 192.168.50.0
network 192.168.60.0
network 192.168.70.0
network 192.168.80.0
network 192.168.90.0
auto-summary
!
router ospf 10
log-adjacency-changes
network 1.1.1.0 0.0.0.3 area 10
network 192.168.10.0 0.0.0.255 area 10
network 192.168.20.0 0.0.0.255 area 10
network 192.168.30.0 0.0.0.255 area 10
network 192.168.40.0 0.0.0.255 area 10
network 192.168.60.0 0.0.0.255 area 10
network 192.168.70.0 0.0.0.255 area 10
network 192.168.80.0 0.0.0.255 area 10
network 192.168.90.0 0.0.0.255 area 10
network 192.168.50.0 0.0.0.255 area 10
!
ip classless
!
line vty 0 4
login
!
end
Configuration of Router MERINDA :-
Router#sh run
Building configuration...
Current configuration : 2178 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
spanning-tree mode pvst
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 2.2.2.1 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0/0
ip address 100.100.100.1 255.255.255.252
ip access-group 101 in
clock rate 2000000
!
interface Serial0/0/1
ip address 10.0.0.1 255.255.255.192
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
no ip address
!
router eigrp 100
redistribute static metric 30000 1 255 255 1500
network 2.2.2.0 0.0.0.3
auto-summary
!
router eigrp 10
network 10.0.0.0
auto-summary
!
router ospf 10
log-adjacency-changes
redistribute static subnets
network 1.1.1.0 0.0.0.3 area 10
network 10.0.0.0 0.0.0.63 area 10
!
ip classless
ip route 0.0.0.0 0.0.0.0 100.100.100.2
!
end
Configuration of Router ISP-I :-
Router#sh run
Building configuration...
Current configuration : 1984 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
spanning-tree mode pvst
!
interface Serial0/0/0
ip address 100.100.100.2 255.255.255.252
!
interface Serial0/0/1
ip address 100.100.100.5 255.255.255.252
clock rate 2000000
!
interface Vlan1
no ip address
shutdown
!
router bgp 100
bgp log-neighbor-changes
no synchronization
neighbor 100.100.100.6 remote-as 200
network 100.100.100.4 mask 255.255.255.252
redistribute static
!
ip classless
ip route 0.0.0.0 0.0.0.0 100.100.100.1
!
line vty 0 4
login
!
end
Configuration of Router ISP-2 :-
Router#sh run
Building configuration...
Current configuration : 2309 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
spanning-tree mode pvst
!
interface Serial0/0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0/0.100 point-to-point
ip address 201.209.64.105 255.255.255.252
frame-relay interface-dlci 100
!
interface Serial0/0/0.200 point-to-point
ip address 201.209.64.101 255.255.255.252
frame-relay interface-dlci 200
!
interface Serial0/0/1
ip address 100.100.100.6 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
router eigrp 25
redistribute bgp 200 metric 30000 1 255 255 1500
network 201.209.64.100 0.0.0.3
network 201.209.64.104 0.0.0.3
auto-summary
!
router bgp 200
bgp log-neighbor-changes
no synchronization
neighbor 100.100.100.5 remote-as 100
network 100.100.100.4 mask 255.255.255.252
redistribute eigrp 25
!
ip classless
!
line vty 0 4
login
!
end
Configuration of Multilayer Switch0 :-
Switch#sh run
Building configuration...
Current configuration : 4131 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
ip dhcp excluded-address 192.168.10.1 192.168.10.2
ip dhcp excluded-address 192.168.20.1 192.168.20.2
ip dhcp excluded-address 192.168.30.1 192.168.30.2
ip dhcp excluded-address 192.168.40.1 192.168.40.2
ip dhcp excluded-address 192.168.50.1 192.168.50.2
ip dhcp excluded-address 192.168.60.1 192.168.60.2
ip dhcp excluded-address 192.168.70.1 192.168.70.2
ip dhcp excluded-address 192.168.80.1 192.168.80.2
ip dhcp excluded-address 192.168.90.1 192.168.90.2
!
ip dhcp pool vlan10
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 192.168.50.100
ip dhcp pool vlan20
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
dns-server 192.168.50.100
ip dhcp pool vlan30
network 192.168.30.0 255.255.255.0
default-router 192.168.30.1
dns-server 192.168.50.100
ip dhcp pool vlan40
network 192.168.40.0 255.255.255.0
default-router 192.168.40.1
dns-server 192.168.50.100
ip dhcp pool vlan50
network 192.168.50.0 255.255.255.0
default-router 192.168.50.1
dns-server 192.168.50.100
ip dhcp pool vlan60
network 192.168.60.0 255.255.255.0
default-router 192.168.60.1
dns-server 192.168.50.100
ip dhcp pool vlan70
network 192.168.70.0 255.255.255.0
default-router 192.168.70.1
dns-server 192.168.50.100
ip dhcp pool vlan80
network 192.168.80.0 255.255.255.0
default-router 192.168.80.1
dns-server 192.168.50.100
ip dhcp pool vlan90
network 192.168.90.0 255.255.255.0
default-router 192.168.90.1
dns-server 192.168.50.100
ip routing
!
spanning-tree mode pvst
spanning-tree vlan 50,60,70,80 priority 4096
spanning-tree vlan 10,20,30,40,90 priority 28672
!
interface FastEthernet0/1
no switchport
ip address 1.1.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/2
no switchport
ip address 3.3.3.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0
!
interface Vlan30
ip address 192.168.30.1 255.255.255.0
!
interface Vlan40
ip address 192.168.40.1 255.255.255.0
!
interface Vlan50
ip address 192.168.50.1 255.255.255.0
!
interface Vlan60
ip address 192.168.60.1 255.255.255.0
!
interface Vlan70
ip address 192.168.70.1 255.255.255.0
!
interface Vlan80
ip address 192.168.80.1 255.255.255.0
!
interface Vlan90
ip address 192.168.90.1 255.255.255.0
!
router eigrp 100
network 3.3.3.0 0.0.0.3
network 192.168.10.0
network 192.168.20.0
network 192.168.30.0
network 192.168.40.0
network 192.168.50.0
network 192.168.60.0
network 192.168.70.0
network 192.168.80.0
network 192.168.90.0
auto-summary
!
router ospf 10
log-adjacency-changes
network 1.1.1.0 0.0.0.3 area 10
network 192.168.10.0 0.0.0.255 area 10
network 192.168.20.0 0.0.0.255 area 10
network 192.168.30.0 0.0.0.255 area 10
network 192.168.40.0 0.0.0.255 area 10
network 192.168.60.0 0.0.0.255 area 10
network 192.168.70.0 0.0.0.255 area 10
network 192.168.80.0 0.0.0.255 area 10
network 192.168.90.0 0.0.0.255 area 10
network 192.168.50.0 0.0.0.255 area 10
!
ip classless
!
line vty 0 4
login
!
end
Configuration of Router MERINDA :-
Router#sh run
Building configuration...
Current configuration : 2178 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
spanning-tree mode pvst
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 2.2.2.1 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0/0
ip address 100.100.100.1 255.255.255.252
ip access-group 101 in
clock rate 2000000
!
interface Serial0/0/1
ip address 10.0.0.1 255.255.255.192
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
no ip address
!
router eigrp 100
redistribute static metric 30000 1 255 255 1500
network 2.2.2.0 0.0.0.3
auto-summary
!
router eigrp 10
network 10.0.0.0
auto-summary
!
router ospf 10
log-adjacency-changes
redistribute static subnets
network 1.1.1.0 0.0.0.3 area 10
network 10.0.0.0 0.0.0.63 area 10
!
ip classless
ip route 0.0.0.0 0.0.0.0 100.100.100.2
!
end
Configuration of Router ISP-I :-
Router#sh run
Building configuration...
Current configuration : 1984 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
spanning-tree mode pvst
!
interface Serial0/0/0
ip address 100.100.100.2 255.255.255.252
!
interface Serial0/0/1
ip address 100.100.100.5 255.255.255.252
clock rate 2000000
!
interface Vlan1
no ip address
shutdown
!
router bgp 100
bgp log-neighbor-changes
no synchronization
neighbor 100.100.100.6 remote-as 200
network 100.100.100.4 mask 255.255.255.252
redistribute static
!
ip classless
ip route 0.0.0.0 0.0.0.0 100.100.100.1
!
line vty 0 4
login
!
end
Configuration of Router ISP-2 :-
Router#sh run
Building configuration...
Current configuration : 2309 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
spanning-tree mode pvst
!
interface Serial0/0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0/0.100 point-to-point
ip address 201.209.64.105 255.255.255.252
frame-relay interface-dlci 100
!
interface Serial0/0/0.200 point-to-point
ip address 201.209.64.101 255.255.255.252
frame-relay interface-dlci 200
!
interface Serial0/0/1
ip address 100.100.100.6 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
router eigrp 25
redistribute bgp 200 metric 30000 1 255 255 1500
network 201.209.64.100 0.0.0.3
network 201.209.64.104 0.0.0.3
auto-summary
!
router bgp 200
bgp log-neighbor-changes
no synchronization
neighbor 100.100.100.5 remote-as 100
network 100.100.100.4 mask 255.255.255.252
redistribute eigrp 25
!
ip classless
!
line vty 0 4
login
!
end
ciscotarun@gmail.com
ReplyDeleteHey rocky
ReplyDeleteHave you received the labs???
neo_raxo@hotmail.com
ReplyDeletejuliolapaca@upsa.bo
ReplyDeletethanks for the help! :)
hey julio .. you are welcome ... :)
ReplyDeletesbdtaw@gmail.com
ReplyDeleteThanks
mnak1983@gmail.com thanks
ReplyDeletesh.regina14@gmail.com
ReplyDeletePlease send me asap.
shif812@gmail.com
ReplyDeletePlease send me.thnx